ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Something strange in your ENVI-met? Please post here...
Post Reply
A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

To whom it may concern,

I am currently facing a serious issue, causing my simulation to stop. It states: "ERROR: Number of new walls: 95947 Number of old walls: 95023" and a waring: "ENVI-met Version 4.0 has stopped working. A problem caused the program to stop working correctly."

Please help me as this is urgent.

Thank you.

Regards,
Avgousta

helge
Posts: 307
Joined: Mon May 15, 2017 12:27 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by helge »

Dear Avgousta,

Typically, the warning is of no concern. It is simply a check of two algorithms calculating the number of walls in the model area.
The simulation window might freeze at times - this does not mean that the simulation is not running anymore

Best
Helge

A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

Hi Helge,

Thank you for the prompt reply.

It does not freeze. It crushes and it stops the simulation by closing down the program.

I have used detailed 3D. Is there any space requirements that might cause the problem? I have 16GB available memory.

I have attached the picture.

Please let me know.

Thank you.
Attachments
MicrosoftTeams-image.png

A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

It looks like the software crashes when trying to build the 1D plants (grass areas). I removed all grass areas, and it looks like it is simulating fine now!

I tried to change to another 1D plant (simple plant) but I get the same issue. Is it because I am in 3D mode? How can I use grass areas now?

helge
Posts: 307
Joined: Mon May 15, 2017 12:27 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by helge »

Hi,

Did you add new simple plants?
Try converting back to concept design in SPACES and re-run the simulation

Best
Helge

A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

Hi Helge,

I have tested other grass types from library too and I have tested also converting it back to 2.5D (although it loses a lot of information so not convenient either ways), but nothing works.

Although I have tested old models in 2.5D space and 1D plants grid fine, I need to have tunnels and podiums, so 2.5D space is not suitable.

Is there anything else I can try? As a note, this is a business project so there are specific timeframes that need to be met. Any support would be appreciated.

I saw that someone recently posted something similar. Please see attached.


Thank you.

Avgousta
Attachments
Capture.JPG

helge
Posts: 307
Joined: Mon May 15, 2017 12:27 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by helge »

Hi Avgousta,

can you upload your INX, Database (EDB) and SIMX files please?
What is your gridding resolution?

Best
Helge

A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

Hi Helge,

I have only used materials that are within the default database. However, as this project is business related, it can only be shared for support with you and deleted after. If I upload here, would that be the case?

it is 2x2m grid in a 200x200x150 grid area.

Please let me know and I can upload files.

Thank you.

helge
Posts: 307
Joined: Mon May 15, 2017 12:27 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by helge »

Dear Avgousta,

I will have a look

Best
Helge

A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

Thank you.


Regards,
Avgousta

helge
Posts: 307
Joined: Mon May 15, 2017 12:27 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by helge »

Hi,

I checked it: Three things

1) Major problem: You should disable precipitation: Your FOX files has negative precipitation values of -500 mm per hour (I attached the corrected SIMX file)
2) Major problem: Your vertical gridding is completely wrong (see screenshot). You have 150 vertical grids that reach up to more than 2500 meters. With 200 x 200 x 150 grids you would need 200 GB of memory or even more
3) Hopefully minor problem: The horizontal distance between buildings and border might not be enough – remove some more cells at the border or increase the model area with empty cells

The biggest problem is the second one: To fix the second problem you will have to first convert to concept design, then adjust your vertical gridding (suggestion is attached) and then only if really needed reconvert to detailed design.

Best
Helge

A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

Thank you for your help.

Kind regards,
Avgousta

A_sta
Posts: 8
Joined: Fri Jun 04, 2021 5:09 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by A_sta »

Dear Helge,

I have made the changes and I have forced the information from fox file except precipitation.

Looks like it is running ok until it gives me the attached warning. Then it just stays there with 0% action in the task manager in CPU/GPU.

File setups also attached. Is it because of the space issues from the border?

Thank you.

Regards,
Avgousta
Attachments
Capture3.JPG
Capture2.JPG.png

helge
Posts: 307
Joined: Mon May 15, 2017 12:27 pm

Re: ENVI-met Version 4.0 has stopped working -ERROR: Number of new walls: 95947 Number of old walls: 95023

Post by helge »

Hi,

Yes it might be the border. If the error persists, please send the updated files to me again

Best
Helge

Post Reply